Magento Myapi_Myconf API : Create Configurable Product

I propose my module under license and with my module, you will be able to create configurable product pragmatically using your preferred development language (php, java, …) !

The module permits the creation of configurable product using the WSDL v1 and v2 API interface. The schema is WSL/WS-I compliant.

Continuer la lecture

Publié dans Magento Module | Marqué avec , , , | 2 commentaires

My blog is online again!

I had a corruption of my database and I thought I lost everything but I found where the corruption came from!

My blog on Magento will be able to resume and I will share my migration to Magento 2.3 here!

 

Publié dans Magento | Laisser un commentaire

Mon blog est à nouveau en ligne !

J’ai eu une corruption de ma base de données et je pensais avoir tout perdu mais j’ai trouvé d’ou venait la corruption !

Mon blog sur Magento va pouvoir reprendre et je partagerai ici ma migration vers Magento 2.3 !

Nicolas Portais
Author Photographer
http://photos-art.pro/

 

Publié dans Articles, Articles, Articles, Magento | Marqué avec , , | Laisser un commentaire

Upgrade to 1.9.3.3 or SUPEE-8167 by June 30, 2017

There is a new patch 1.9.3.3 or apply the patch SUPEE-8167.

For PayPal, this patch must be installed before June 30, 2017. It enables https for the IPN connection.

If you have errors during the upgrade :

Error: 
upgrade-all: Failed to delete files: /home/data/www/magento_docker/./pkginfo/Mage_All_Latest.txt 
 Check permissions
Error: 
upgrade-all: Package community/Interface_Adminhtml_Default 1.9.3.2 conflicts with: community/Mage_All_Latest 1.9.3.1
Error: 
upgrade-all: Package community/Interface_Frontend_Default 1.9.3.2 conflicts with: community/Mage_All_Latest 1.9.3.1
...

you can check my previous article : Magento 1.9.3 : Security patch SUPEE-8788

Nicolas Portais
Author Photographer
http://www.mystockphoto.fr/
http://photos-art.pro/

 

Laisser un commentaire

Magento: Compare two Magento themes (diff)

Actually explained into my previous article Magento : Do you have issue with your bundled product ?, I am updated my template using the RWD (Responsive Web Design) theme as reference.

You will find below how to find quickly modified files :

for i in $(find . -name "*.phtml")
do 
if [ -f "$i" -a -f "../../../rwd/PhotosArtRwd/template/$i" ]
then
  echo "************** : $i ****************"
  diff -Naur $i ../../../rwd/PhotosArtRwd/template/$i
  echo "END $i *******"
  read break
fi
done

I am used the same tip than my previous article : Magento: Check your modified Magento class (diff)

I hope It was useful for you.

Nicolas Portais
Author Photographer
http://www.mystockphoto.fr/
http://photos-art.pro/

Publié dans Anglais, Magento | Marqué avec , , , , , | Laisser un commentaire

Magento : Do you have issue with your bundled product ?

It seems that the latest release of Magento 1.9.3.X breaks old theme due to javascript codes missing.

You may have the following errors :

TypeError: Product.OptionsPrice is not a constructor
TypeError: optionsPrice is undefined
TypeError: bundle is undefined
TypeError: bundle is undefined

Continuer la lecture

Publié dans Anglais, Magento | Marqué avec , , , , , , , | Un commentaire

Magento 1.9.3.2: SUPEE-9652 Resolve Zend Framework Security Issue – 2/7/2017

As you have certainly seen, Magento has released a new patch SUPEE-9652 for version 1.9 (community edition in my case).

If you have errors during the upgrade :

Error: 
upgrade-all: Failed to delete files: /home/data/www/magento_docker/./pkginfo/Mage_All_Latest.txt 
 Check permissions
Error: 
upgrade-all: Package community/Interface_Adminhtml_Default 1.9.3.2 conflicts with: community/Mage_All_Latest 1.9.3.1
Error: 
upgrade-all: Package community/Interface_Frontend_Default 1.9.3.2 conflicts with: community/Mage_All_Latest 1.9.3.1
...

you can check my previous article : Magento 1.9.3 : Security patch SUPEE-8788

Nicolas Portais
Author Photographer
http://www.mystockphoto.fr/
http://photos-art.pro/

 

Publié dans Magento | Marqué avec , , , , , | Un commentaire

Mac OS X : How to install an old Java version under MacOS Sierra ?

 

I am using MacOS sierra but I have applications that need the JVM version 6.0

I don’t recommend you to install an older Java version on MacOS sierra as you will brake your system.

You will find below the solution

Continuer la lecture

Publié dans Anglais, Computer / Technic / Technology | Marqué avec , , , , , , , , , , | Laisser un commentaire

Run Magento into docker

Since some weeks, my e-commerce store is running under Docker !

In fact, an upgrade of my linux distribution had broken my Magento installation and I have decided to migrate it into a docker container : It is more secure and an host upgrade will not impact the container and version installed.

Continuer la lecture

Publié dans Anglais, Magento | Marqué avec , , , , , , , , | Un commentaire

Mac OS X : Server 5.2 : How to rebuild PHP Postgresql modules ?

If you are using the Server.app 5.2 under El Capitan or older, you have issues with the Postgresql PHP  modules !

These modeules are compiled for php available under macOS sierra (PHP 5.6.25 – API=20131226). Under El Capitan, PHP 5.5.38 (API=20121212) is provided

and  when you run php, It complains about the API mismatch : Continuer la lecture

Publié dans Anglais, Computer / Technic / Technology | Marqué avec , , , , , , , , , | 3 commentaires

Magento 1.9.3 : Security patch SUPEE-8788

Magento has released a new patch SUPEE-8788 for Magento which fixes Zend framework and payment vulnerabilities.

Continuer la lecture

Publié dans Magento | Marqué avec , , , , , | 3 commentaires

Let’s Encrypt : A Free SSL/TLS Certificate Authority

I am usually using an auto-signed certificate for my personal website but the navigators are blocking non-valid certificates.

I have found an alternative and discovered Let’s Encrypt which is a free Certificate Authority (CA) : The certificate signed by this CA are recognized by all the navigators. So It is a real valid certificate. 😉 Continuer la lecture

Publié dans Anglais, Computer / Technic / Technology | Marqué avec , , , , , , , | Laisser un commentaire

How Healthy Is Your Magento Store?

I have received an email from Sam asking me to add a link to her web site :
How Healthy Is Your Magento Store?

As the security is important, I am sharing below an extra of her blog article :

Offering a dynamic shopping cart experience together with content and functionality management, Magento is a complete solution for your open source ecommerce requirements.

With an effortless and user friendly architecture, Magento includes all essentials, defining a comprehensive online store. Easy to install and convenient to add plugins, it’s a preferred choice for big and small businesses alike.

Effective management of your Magento store brings an imperative accountability to maintain its health and privacy at all times. While it’s important to keep your Magento store safe, a sustained focus on your business and user experience is more significant from long term perspective.

The below infographic amply illustrates the symptoms that you must keep an eye on while administering your Magento store. As you concentrate on the primary reasons for your slow running store, it helps you to drive measures towards fixing them and retaining the much needed store performance.

User experience can further be amplified by following some plain rules that have now become vital than just being defined as add-ons.

Continuer la lecture

Publié dans Magento | Laisser un commentaire

Magento 1.9.2.4: Security Patch SUPEE-7405 v1.1

Magento has released a new patch for Magento which includes the SUPEE-7405 v1.1 Patch Bundle.

Continuer la lecture

Publié dans Magento | Laisser un commentaire

Magento 1.9.2.3: Security Patch SUPEE-7405

Magento has released a new upgrade for Magento which includes the SUPEE-7405 Patch Bundle.

Continuer la lecture

Publié dans Magento | Marqué avec , , , , | Laisser un commentaire

Magento 2 is released !

Magento 2 is now released and It is now the time to study the migration. You will find an migration overview how to proceed on the Magento website.

I am starting the migration in a test environment and I will update this article.

Continuer la lecture

Publié dans Magento | Marqué avec , , , , , | Un commentaire

Magento 1.9.2.2 : SUPEE-6788 security patch

Magento has released a new upgrade for Magento which includes the SUPEE-6788 Patch Bundle. Note that this upgrade can break some modules which are not correctly coded.

Continuer la lecture

Publié dans Magento | Marqué avec , , , , , | Un commentaire

Magento 1.9.2.1 : Include SUPEE-6482 Patch Bundle

Magento has released a new update for Magento which includes the SUPEE-6482 Patch Bundle. See also my post for the magento version 1.9.2.2

Continuer la lecture

Publié dans Anglais, Magento | Marqué avec , , , , , | Laisser un commentaire

How to secure your website ? Docker !

Hello,

I worked these few days how to secure my website and limit the impact in case of attack. Linux is secure but there are always bugs and breaks….generally into the plugins, templates, etc…

I have explored all the possibility under Linux and I choose Docker to secure my website : It takes more memory because you create several instances but you isolates and limits  the impact in case of attach.

To install Docker under Linux (Ubuntu), follow these steps: Continuer la lecture

Publié dans Anglais, Computer / Technic / Technology | Marqué avec , , , , , , , , , , , | Laisser un commentaire

Magento: 1.9.2.0: Small Cache bug for CMS Block

I have updated to the version 1.9.2.0 of the new release Magento Patch (See my article here) and I have noted a small bug.

I have noted that the cms blocks of my home page were not showing. The problem disappeared when I disable the « Page blocks HTML » cache. I tried to refresh the cache without success. Continuer la lecture

Publié dans Anglais, Magento | Marqué avec , , , , , , | Un commentaire

Magento: Security Patch (SUPEE-6285) – Install Immediately

You have certainly received an email from Magento about a Security Patch (SUPEE-6285).

This patch must be installed immediately.

See the Magento’s website Continuer la lecture

Publié dans Anglais, Magento | Marqué avec , , , , , , , | Un commentaire